npm

npm’s 2019 JavaScript ecosystem survey analysis is now available!Get your copy here »

slice-ansi

0.0.4 • Public • Published

slice-ansi

Build Status XO: Linted

Slice a string with ANSI escape codes

Install

$ npm install --save slice-ansi

Usage

var chalk = require('chalk');
var sliceAnsi = require('slice-ansi');
 
var input = 'The quick brown ' + chalk.red('fox jumped over ') +
    'the lazy ' + chalk.green('dog and then ran away with the unicorn.');
 
console.log(sliceAnsi(input, 20, 30));

API

sliceAnsi(input, beginSlice[, endSlice])

input

Type: string

String with ANSI escape codes. Like one styled by chalk.

beginSlice

Type: number

The zero-based index at which to begin the slice.

endSlice

Type: number

Optional. The zero-based index at which to end the slice.

Related

  • chalk - Terminal string styling done right

License

MIT © David Caccavella

install

npm i slice-ansi

Downloadsweekly downloads

9,212,401

version

0.0.4

license

MIT

homepage

github.com

repository

Gitgithub

last publish

collaborators

  • avatar
  • avatar
  • avatar
Report a vulnerability